Commit 6a4b7899 authored by Christian Beer's avatar Christian Beer

BUILD: fix curl detection

Since curl is needed for the libraries and the libraries are needed for everything else check for libcurl by default.
parent a52e9b99
......@@ -440,18 +440,15 @@ BOINC_CHECK_FCGI
fi
dnl ---------- libcurl (m4/libcurl.m4) ------------------------------
dnl curl is needed for libraries and those are needed by everything else
if test "${enable_client}" = yes; then
LIBCURL_CHECK_CONFIG([yes], [7.17.1], [haveCurl=yes], [haveCurl=no])
LIBCURL_CHECK_CONFIG([yes], [7.17.1], [haveCurl=yes], [haveCurl=no])
if test "${haveCurl}" != yes; then
if test "${haveCurl}" != yes; then
AC_MSG_ERROR([
================================================================================
ERROR: could not find (recent enough) development-libs for libcurl.
This library is required to build the boinc-client.
(If you don't want to build the client, use --disable-client with configure.
If libcurl-dev is installed on your system, make sure that the script
'curl-config' is found in your PATH, and that
'curl-config --version' gives something recent enough (see above).
......@@ -460,7 +457,7 @@ ERROR: could not find (recent enough) development-libs for libcurl.
================================================================================
])
else
else
## add libcurl et al. to the list of statically linked libs
STATIC_LIB_LIST="${STATIC_LIB_LIST} curl idn ssh2 crypto ssl krb5 k5crypto gssapi_krb5 com_err resolv lber ldap socket nsl z rt gcrypt gpg-error"
CPPFLAGS="${CPPFLAGS} ${LIBCURL_CPPFLAGS}"
......@@ -473,9 +470,6 @@ ERROR: could not find (recent enough) development-libs for libcurl.
echo "LDFLAGS = ${LDFLAGS}"
fi
BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${LIBCURL}"
fi
fi
dnl ---------- SSL (m4/check_ssl.m4)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment