Commit dd7e33f5 authored by Rom Walton's avatar Rom Walton

*** empty log message ***

svn path=/trunk/boinc/; revision=10707
parent 41a7ebad
......@@ -17,12 +17,6 @@ AC_ARG_ENABLE(debug,
[enable_debug=yes],
[])
AC_ARG_ENABLE(unicode,
AS_HELP_STRING([--enable-unicode],
[enable building the manager with unicode support]),
[enable_unicode=yes],
[])
AC_ARG_ENABLE(server,
AS_HELP_STRING([--disable-server],
[disable building the scheduling server]),
......@@ -35,6 +29,12 @@ AC_ARG_ENABLE(client,
[],
[enable_client=yes])
AC_ARG_ENABLE(unicode,
AS_HELP_STRING([--disable-unicode],
[disable building the manager with unicode support]),
[],
[enable_unicode=yes])
m4_divert_once([HELP_ENABLE],
AS_HELP_STRING([], [Default: --enable-server --enable-client:
builds both server and client]))
......@@ -473,31 +473,38 @@ AM_OPTIONS_WXCONFIG
dnl check for wxWidgets
if test "${enable_client_release}" = yes ; then
echo 'Portable client-build: checking for *static* wx-libs ...'
if test "${enable_debug}" = yes ; then
if test "${enable_unicode}" = yes ; then
echo 'Portable client-build: checking for debug unicode wx-libs ...'
AM_PATH_WXCONFIG([2.6.0], [wxWin=1], [wxWin=0], --static=yes --unicode=yes --debug=yes)
else
echo 'Portable client-build: checking for debug wx-libs ...'
AM_PATH_WXCONFIG([2.6.0], [wxWin=1], [wxWin=0], --static=yes --unicode=no --debug=yes)
fi
else
if test "${enable_unicode}" = yes ; then
echo 'Portable client-build: checking for unicode wx-libs ...'
AM_PATH_WXCONFIG([2.6.0], [wxWin=1], [wxWin=0], --static=yes --unicode=yes --debug=no)
else
echo 'Portable client-build: checking for wx-libs ...'
AM_PATH_WXCONFIG([2.6.0], [wxWin=1], [wxWin=0], --static=yes --unicode=no --debug=no)
fi
fi
else
if test "${enable_debug}" = yes ; then
if test "${enable_unicode}" = yes ; then
echo 'checking for debug unicode wx-libs ...'
AM_PATH_WXCONFIG([2.6.0], [wxWin=1], [wxWin=0], --unicode=yes --debug=yes)
else
echo 'checking for debug wx-libs ...'
AM_PATH_WXCONFIG([2.6.0], [wxWin=1], [wxWin=0], --unicode=no --debug=yes)
fi
else
if test "${enable_unicode}" = yes ; then
echo 'checking for unicode wx-libs ...'
AM_PATH_WXCONFIG([2.6.0], [wxWin=1], [wxWin=0], --unicode=yes --debug=no)
else
echo 'checking for wx-libs ...'
AM_PATH_WXCONFIG([2.6.0], [wxWin=1], [wxWin=0], --unicode=no --debug=no)
fi
fi
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment