Commit 4212ce22 authored by Karsten Wiesner's avatar Karsten Wiesner 💬
Browse files

trimmed and debugged vagrant bootstrap file (do everything automatically now)

parent 1b450f5f
......@@ -13,7 +13,9 @@ Vagrant.configure("2") do |config|
# Every Vagrant development environment requires a box. You can search for
# boxes at https://vagrantcloud.com/search.
# config.vm.box = "hashicorp/precise64"
config.vm.box = "ubuntu/trusty64"
# Disable automatic box update checking. If you disable this, then
# boxes will only be checked for updates when the user runs
# `vagrant box outdated`. This is not recommended.
......@@ -49,7 +51,9 @@ Vagrant.configure("2") do |config|
# backing providers for Vagrant. These expose provider-specific options.
# Example for VirtualBox:
#
config.vm.provider "virtualbox" do |vb|
# # Display the VirtualBox GUI when booting the machine
# vb.gui = true
#
......@@ -57,8 +61,8 @@ Vagrant.configure("2") do |config|
# vb.memory = "1024"
vb.customize ["modifyvm", :id, "--memory", "4096"]
end
#
# View the documentation for the provider you are using for more
# information on available options.
......
......@@ -22,7 +22,10 @@ sudo pip install pyRXP
sudo pip install pyephem
sudo pip install pycallgraph
sudo apt-get install graphviz
sudo apt-get -y install graphviz
sudo git config --global user.email "albert_einstein@example.com"
sudo git config --global user.name "Albert Einstein"
# append to .profile
(
......@@ -48,27 +51,19 @@ cd /home/vagrant/src/lisasolve/mc3
sudo python setup.py install -v
cd /home/vagrant/src/synthlisa
cat extend-synthlisa-by-phasemeter-noise.patch | git am
cat /vagrant/extend-synthlisa-by-phasemeter-noise.patch | git am
sudo python setup.py install
chown -R vagrant:vagrant /home/vagrant/*
# Things to be done manually
# ssh-keygen -o -t rsa -C "your.email@example.com" -b 4096
# put the public key into your gitlab profile
# git clone git@gitlab.aei.uni-hannover.de:swetashah/xtalklisapropagation.git
# git config --global user.email "you@example.com"
# git config --global user.name "Your Name"
# devops notes ------------------------------------------------------------
# If fft memory error occures like
# File "/usr/lib/python2.7/dist-packages/numpy/fft/fftpack.py", line 75, in _raw_fft
# r = work_function(a, wsave)
# MemoryError
# change "Vagrantfile" configuration to more memory e.g. 4096
# > vagrant reload
#
# Use newer OSs like Ubuntu 14.04.5 LTS
# Reason:
# all python sites need to be accessd with TLS1.2. which comes with openssl
......@@ -76,7 +71,7 @@ chown -R vagrant:vagrant /home/vagrant/*
# http://pyfound.blogspot.com/2017/01/time-to-upgrade-your-python-tls-v12.html
# test python tls version to mitigate the tlsv1 alert protocol error (not able to https access)
# python -c "import json, urllib2; print json.load(urllib2.urlopen('https://www.howsmyssl.com/a/check'))['tls_version']"
#
# If the very latest python version 2.7.9 is needed
#sudo apt-get -y install --reinstall build-essential
#sudo apt-get install libreadline-gplv2-dev libncursesw5-dev libssl-dev libsqlite3-dev tk-dev libgdbm-dev libc6-dev libbz2-dev
......@@ -85,4 +80,4 @@ chown -R vagrant:vagrant /home/vagrant/*
#cd Python-2.7.9
#./configure
#make
#sudo make install
\ No newline at end of file
#sudo make install
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment