Commit b0faa773 authored by Gregory Ashton's avatar Gregory Ashton
Browse files

Update matplotlib dependency to prevent confusing error message

Requirement is matplotlib>=1.4 in order to use the style package. Make the
default context ggplot (available in 1.4) and add an error message to
help the user when they have selected one which does not exist.
parent 19d367dd
......@@ -44,7 +44,7 @@ $ git clone git@gitlab.aei.uni-hannover.de:GregAshton/PyFstat.git
`pyfstat` makes uses the following external python modules:
* [numpy](http://www.numpy.org/)
* [matplotlib](http://matplotlib.org/)
* [matplotlib](http://matplotlib.org/) >= 1.4
* [scipy](https://www.scipy.org/)
* [emcee](http://dan.iel.fm/emcee/current/)
* [corner](https://pypi.python.org/pypi/corner/)
......
......@@ -771,9 +771,14 @@ class MCMCSearch(core.BaseSearchClass):
def _plot_walkers(self, sampler, symbols=None, alpha=0.4, color="k",
temp=0, lw=0.1, nprod=0, add_det_stat_burnin=False,
fig=None, axes=None, xoffset=0, plot_det_stat=False,
context='classic', subtractions=None, labelpad=0.05):
context='ggplot', subtractions=None, labelpad=0.05):
""" Plot all the chains from a sampler """
if context not in plt.style.available:
raise ValueError((
'The requested context {} is not available; please select a'
' context from `plt.style.available`').format(context))
if np.ndim(axes) > 1:
axes = axes.flatten()
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment