set minimum python3 requirement
As discussed in #17 (closed):
@GregAshton @ReinhardPrix should we just deprecate python 2 for this package (and set an explicit minimum version in the setup), instead of investing energy into maintaining separate package requirements?
Yes, totally, I'm actually for setting the minimum to 3.7 or even the newly-released 3.8 and never looking back. Any python version can easily be installed either via pyenv or conda or similar ...
3.7 could be ok, while 3.8 is a bit too bleeding edge (e.g. no lalsuite wheels are built for it yet, see https://git.ligo.org/lscsoft/lalsuite/issues/212 ); but for the moment I'd prefer even 3.5 as the minimum (to keep Debian Stretch supported).
I just found out that the black style checker doesn't support 3.5 anymore, so yeah, I definitely have to admit that version is on its way out. I suggest we do one release after my current set of MRs with 3.5 as the minimum requirement, then immediately after bump to 3.6 for any further development work.